Limited Functionality of the Lead Manager
Incident Report for Conversica Status Page
Resolved
This incident has been resolved.
Posted Jul 26, 2023 - 09:36 PDT
Investigating
Our team has received several reports regarding the limited functionality of the Lead Manager.

Our team is diligently working to identify the problem and restore full functionality to the Lead Manager. However, during this time, you might encounter occasional disruptions while accessing or using the platform.
Posted Jul 26, 2023 - 08:52 PDT
This incident affected: Dashboard (Lead Manager).